Compatibilité de MySQL Server avec JMap / Compatibility of MySQL Server with JMap

Produit concerné / Related product

JMap ServerVersionsJMap 7 Gibraltar


Jump to English version

Problème

JMap Gibraltar introduit la nouvelle version du connecteur ODBC 8.0.12 de MySQL Server qui assure la compatibilité entre JMap et les bases de données MySQL 8.0, 5.7, 5.6 et 5.5. Toutefois, ce nouveau connecteur n'est pas rétrocompatible avec les anciennes versions MySQL, il est donc nécessaire de retourner à une version plus ancienne du connecteur pour assurer la compatibilité entre JMap et MySQL Server.


Note : Il n'est pas possible d'utiliser les deux pilotes en même temps. Il est donc important de vous assurer que les versions des bases de données MySQL utilisées dans JMap sont soit 5.1 et moins ou 5.5 et plus, afin de respectivement utiliser l'ancien pilote (mysql-connector-java-5.1.34.jar) ou le pilote le plus récent (mysql-connector-java-8.0.12.jar).

Solution



English version


Problem

JMap 7 Gibraltar introduces the new version on the ODBC connecteur 8.0.12 which assures the compatibility between JMap and MySQL Server 8.0, 5.7, 5.6 and 5.5. However, the new connector is not compatible with anterior versions of MySQL Server. To ensure compatibility with JMap and MySQL server, it is then necessary to return to an anterior version of the connector.


Note: It is not possible to use both drivers at the same time. It is therefore important to ensure that the versions of the MySQL databases used in JMAP are either 5.1 or less or 5.5 and above, in order to use respectively the old driver (MySQL-connector-java-5.1.34. jar) or the most recent driver ( MySQL-connector-java-8.0.12. jar).

 Solution